Funciones CONTAR en Excel

En un artículo anterior hablamos de la función SUMAR.SI, una función que nos permitía obtener el total de un rango de valores que cumpliesen una condición. Como ya comentamos esa función tiene una análoga que permite contar, es decir, nos devuelve el número de valores que cumplen la condición.

Esa función se llama CONTAR.SI y necesita únicamente dos parámetros, por un lado, el rango y por otro el criterio. Hemos de darnos cuenta que la función SUMAR.SI podía tener un tercer parámetro en el caso en que el rango de la condición y el rango a sumar no fuesen el mismo: esto, sin embargo, no puede darse CONTAR.SI. Ahora siempre el rango a contar será el mismo que el rango de la condición.

Si partimos de la siguiente tabla:

tabla de cotización de acciones

Imaginemos que queremos determinar cuántas acciones han subido, y cuántas su valor es de más de 10€.
Para ello usamos la función CONTAR.SI:

=CONTAR.SI(E3:E10;”>0”) que nos devolverá 4, el número de acciones que han cotizado en positivo.
=CONTAR.SI(C3:C10;”>10") que nos devolverá 3, aquellas acciones cuyo valor es mayor a 10€.

Además de la función CONTAR.SI también disponemos de otras tres funciones que nos devuelven el cardinal del rango con la única condición del formato del contenido. Esto es nos devuelven, por ejemplo, cuántas celdas contienen números; cuántas celdas contienen algo (ya sea esto texto o número); y por último, cuántas celdas están vacías.

Estas tres funciones son CONTAR(rango), CONTARA(rango) y CONTAR.BLANCO(rango). Como podemos ver su sintaxis es muy sencilla ya que simplemente necesitan un parámetro, el rango de las celdas. Su uso es igual que las funciones SUMAR, PROMEDIO, MAX, MN, etc.

Veamos un ejemplo.

Tabla de distintos valores para funciones de contar

En la siguiente tabla quiero saber:

¿Cuántas celdas tienen almacenado un número? CONTAR(B2:E6) => 10

Número de celdas que contienen algún dato CONTARA(B2:E6) => 15

¿Cuántas celdas hay vacías? CONTAR.BLANCO(B2:E6) => 5

¿Cuántas celdas hay cuyo contenido comienza por v? CONTAR.SI(B2:B6;”V*”) => 3

 

Acabamos con un resumen de la sintaxis y definición de estas cuatro funciones:

CONTAR(rango). Se usa para conocer el número de celdas que contienen datos numéricos.

CONTARA(rango). Nos devuelve el número de celdas que contienen un dato alfanumérico, es decir, el número de celdas que no están vacías.

CONTAR.BLANCO(rango). Utilizada para saber el número de celdas vacías.

CONTAR.SI(rango;criterio). Nos devuelve el número de celdas que cumplen una condición.

Deja un comentario en: “Funciones CONTAR en Excel

Los comentarios están cerrados.