La función Si en Excel

De entre las funciones lógicas la función SI es sin duda ninguna la más importante de ellas y en la que se basan la mayoría de las operaciones lógicas.

La función SI sirve para discriminar entre dos posibilidades atendiendo a una
condición. Del tipo "si ocurre esto haremos la opción A y sino la haremos la opción B". Algunos ejemplos de uso podrían ser, asignar la calificación APTO o NO APTO a un alumno en función de su nota; elegir un tipo impositivo (por ejemplo, un tipo de IVA), dependiendo de la categoría del producto; o bien, aplicar un aumento de sueldo a los empleados teniendo en cuenta su antigüedad en la empresa. En todos esos casos es indicado el uso de la función condicional SI.

Según la sintaxis de la función SI primero colocaremos la condición, después la
operación en caso de que se cumpla y por último, la operación en caso que no se
cumpla:

= SI (CONDICIÓN; VALOR SI VERDADERO; VALOR SI FALSO)

Veamos algunos ejemplos:

Primer Ejemplo: En la celda A3 tenemos guardada la nota de un alumno, un valor entre 0 y 10. Si este valor es mayor o igual que 5 deberá mostrarse el texto
APROBADO. En caso contrario, deberá mostrar SUSPENSO.

La condición será A3>=5. Las opciones se escribirán entre comillas para indicar que se trata de un texto. Quedaría así:

= SI(A3>=5;"APROBADO";"SUSPENSO")

Segundo Ejemplo: Tengamos la siguiente tabla de productos, con la descripción,
precio, unidades, etc.

Ejemplo de tabla de datos para el uso de la función SI

La fórmula que figura en la columna importe es = D3*E3, es decir, multiplicar el
precio por el número de unidades.

En la columna total, la fórmula es F3 + G3, es decir, la suma del IVA más el importe.

Por tanto lo único que nos falta es calcular el IVA y la tabla de gastos la tendríamos completa.

Si nos fijamos, existe una columna llamada tipo, con los valores N y R (normal y
reducido) que nos permite saber que tipo de IVA hemos de aplicar al producto:

La R, es un tipo reducido, aplicable a los productos de alimentación, viajes,
relacionados con la salud, y algunos otros más. Es del 8%.

La N, es tipo normal, aplicable a la mayoría de los productos. Es del 18%.
O sea, a aquellos productos cuyo tipo sea una N, le aplicaremos un 18%, al resto un 8%.

La fórmula nos quedaría:

= SI(C3="N";F3*18%;F3*8%)

Si luego copiamos la fórmula (al tener la fórmula referencias relativas) a todo el
rango G3:G7, obtenemos:

Tabla de tipos de IVA resuelta con función SI

(NOTA: los tipos de IVA son meramente orientativos ya que dependen de cada país, es España por ejemplo, es del 21%).

Tercer Ejemplo: La siguiente tabla muestra un listado de trabajadores y su
antigüedad en la empresa:

Tabla de datos para calcular el sueldo en función de la antiiguedad

El plus de antigüedad es de un 10% sobre el sueldo base para los trabajadores que llevan más de 3 años en la empresa. Los que llevan menos no tienen plus, es decir, es de cero.

La fórmula será:

=SI(C3>3;D3*10%;0)

Una vez copiada en toda la fila, la tabla queda:

Tabla resuelta con la función SI de los salarios por antigüedad

Estos ejemplos ilustran el uso más directo de la función SI, pero si tenemos que elegir entre más de dos opciones podremos usar las funciones SI anidadas (que estudiaremos en artículos posteriores) e incluso las funciones de búsquedas como la función BUSCARV y BUSCARH.

Deja un comentario en: “La función Si en Excel

Los comentarios están cerrados.